Hob displays error message E2
Issue
- Hob displays the error message E2, E20x
- Hob is not working
Applies to
- induction hobs
- ceramic hobs
Resolution
1. Disconnect the appliance from power for at least 30 seconds.
Note: To restart the appliance, disconnect it from the mains and wait 30 seconds before switching it back on.
In the case of built-in appliances, it is not necessary to physically disconnect the cable - the appliance can be disconnected using the household RCD breaker.
2. Contact an Authorized Service Center.
If the above advice does not resolve the problem, we recommend requesting a visit by a service engineer.
Make a note of the reported error code and quote it when you request an engineer. This will not solve your problem, but it will help our engineer identify the cause of the problem.
Cause
- Error message E2 or similar beginning with E2xx indicates an error in LED lighting in induction hobs and an error in the temperature sensor in teppanyaki appliances.
Was this article helpful?
Related Articles
- Hob displays error message E3 / E311 / E312 / E313
- Dropped something on hob / impact damage / cracked glass / care / replace and how to organise a repair
- Hob displays error message E5
- Hob displays message L, the hob is locked
- Hob displays message H
- Discoloured glass plate / ceramic glass cleaning tips
- Hot plate cannot be activated or is not operating
- Hob displays error message E4 / E401 / E402 / E403 / E421 / E422 / E423 / E431 / E432 / E433
- Hob displays error message E7
- Hob displays error message E9
Spare parts & Accessories
Find original spare parts for your appliance in our webshop and have them delivered directly to your door.