Spare parts & AccessoriesSupport ArticlesSupport
  • Spare parts & Accessories
  • Support Articles
  • Support

My Purchase was declined but I still see a Klarna transaction

Issue

I have a balance outstanding in my Klarna account and am not expecting any goods.

Cause

When you attempt to place an order using the Klarna App, funds are reserved and released within 24 hours if unsuccessful.

For more information please refer to Klarna:

https://www.klarna.com/uk/customer-service/my-purchase-was-denied-why-do-i-still-see-a-transaction-to-klarna-on-my-card/

Was this article helpful?

Related Articles

  • I want to know more about a product I'd like to order, how can I do it?
  • I require a VAT receipt. Is it possible to receive it?
  • When will the credit card be charged?
  • What payment methods can I use?
  • What is the waiting time to receive a credit card refund?
  • Ive tried to pay with Klarna and the option is not available or has been declined
  • I would like to change my payment method
  • I purchased using Klarna and not received my confirmation
  • I live in Channel Islands, do I need to pay VAT?
  • I have made a payment using Klarna but not received a refund
Logo

Contact & Support

Contact usSubscribe for newsletterFacebookYoutubeSupportRegister your productDownload manualsDownload brochuresWarrantyRecyclingFAQService Terms & Conditions

About Electrolux

Electrolux GroupPress and newsProduct Safety InformationFinancial informationEnvironmentWork for usAwards & RecognitionAbout usGender Pay GapSlavery and Human TraffickingSection 172 StatementsElectrolux UK Tax Strategy

Discover

Steam OvensInductionCoolingCooker HoodsDishwashersPremium CookwareSupport articles
  • Terms and Conditions of Electrolux website
  • Privacy Statement
  • Cookie Notice
  • Accessibility Information
  • Chat with us